请选择 进入手机版 | 继续访问电脑版

老米之家

 找回密码
 立即注册
查看: 32|回复: 0

建站:错误页面的解决方式

[复制链接]

2881

主题

2881

帖子

1万

积分

论坛元老

Rank: 8Rank: 8

积分
11053
发表于 2022-10-16 09:17:18 | 显示全部楼层 |阅读模式
在使用过程中网站可能会出现“Fatal error Allowed memory size of”  等类似错误,并且我们按照字面意思,就可以知道这是主机内存分配不足,或者是内容溢出错误而导致的,那么如何纠正呢?
通常情况下,我们在网站后台安装扩展模块、上传大图片文件、或者导入数据库时都会引起这样的错误。这主要是因为在执行PHP程序时占用过多的虚拟主机内存而导致的。不过,很多新手站长对于这类棘手问题都束手无策。为此,小编就来介绍下解决“Fatal  error Allowed memory size of”的简单方法。
第一、目前,咱们使用的虚拟主机,内存限制基本都在32M、64M等。所以,当我们遇到这样的错误时,首先就需要改变内存的限制大小,方法如下:
1、新建一个文本文件,并且用EditPlus编辑器(其它类似的编辑器也可以)进行编辑;
2、在文件中写入这样的语句:php_value memory_limit=”512M”;
3、弄好之后,保存该文件,并命名为“php.ini“文件”,然后将文件上传到根目录即可。
备注:目前,很多虚拟主机采用的都是cPanel面板,这样我们可以在cPanel文件管理器中直接创建php.ini文件,然后写入上述代码。当然,如果文件管理器中已经存在php.ini的话,那就直接编辑php.ini加入上述代码就行了。
第二、对于PHP主机空间来说,也可以通过设置setting.php配置文件来更改内存大小,方法如下:
1、首先进入主机控制面板,cPanel面板的话直接进入文件管理器。
2、如果是常见的开源程序,可以按照这个地址:xxx/sites/default/settings.php,找到setting.php文件。
3、直接在线编辑该文件,然后在setting.php文件的最底部加入“Ini_set(‘memory_limit’,’512M’);”代码即可。当然,你也可以将setting.php文件下载到本地电脑,然后利用EditPlus编辑器进行编辑,不过这样可能稍微要繁琐些。
第三、我们还可以在PHP虚拟主机的配置文件.htaccess中进行设置,方法如下:
1、在根目录建立.htaccess配置文件,如果已存在的话,直接编辑即可。
2、然后添加代码“php_value memory_limit 512M。
这种方法比较常用,很多朋友经常在cPanel后台上传文件或图片过大时,都是通过此种方法来更改内存限制大小的。
希望这篇文章可以解决大家相关问题。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|老米之家 ( 蜀ICP备2021018398号-10 )|网站地图

GMT+8, 2022-11-30 18:41 , Processed in 0.044980 second(s), 18 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表